summary refs log tree commit diff
path: root/ripple/fossil/Cargo.toml
diff options
context:
space:
mode:
authoredef <edef@unfathomable.blue>2022-03-24 17:20:22 +0000
committeredef <edef@unfathomable.blue>2022-04-11 17:01:36 +0000
commit891655b2b1ad12b5eaf813a346fc2c177e4fa062 (patch)
tree5d4661dc68afa969b599627b355fe4c4dea303b5 /ripple/fossil/Cargo.toml
parent785a7b77d1b1d0fc6b600af734fdbfcb69dc62ed (diff)
ripple/fossil/mount: init
Minimal no-op FUSE FS.

Change-Id: If6549990a768acea5ac8c75399b71ac10db8a4c6
Diffstat (limited to 'ripple/fossil/Cargo.toml')
-rw-r--r--ripple/fossil/Cargo.toml11
1 files changed, 11 insertions, 0 deletions
diff --git a/ripple/fossil/Cargo.toml b/ripple/fossil/Cargo.toml
index af86d4e..86972c8 100644
--- a/ripple/fossil/Cargo.toml
+++ b/ripple/fossil/Cargo.toml
@@ -12,6 +12,17 @@ bytes = "1.0.1"
 blake3 = { version = "0.3.8", features = ["rayon"] }
 sled = "0.34.6"
 byteorder = "1.4.3"
+fuser = { version = "0.11.0", optional = true }
+log = { version = "0.4.14", optional = true }
+libc = { version = "0.2.112", optional = true }
+env_logger = { version = "0.9.0", optional = true }
 
 [build-dependencies]
 prost-build = "0.8.0"
+
+[features]
+wip-mount = ["fuser", "log", "libc", "env_logger"]
+
+[[bin]]
+name = "mount"
+required-features = ["wip-mount"]