summary refs log tree commit diff
path: root/ripple/fossil/Cargo.toml
diff options
context:
space:
mode:
authoredef <edef@unfathomable.blue>2022-04-11 17:17:31 +0000
committeredef <edef@unfathomable.blue>2022-04-11 17:21:20 +0000
commitb6efed641aecd3d2f9922c7eb2fa1a3d75657518 (patch)
tree4390f0ef3205d5ec5dcb545a7f8b193bec955f43 /ripple/fossil/Cargo.toml
parent43eca585e23e1c5f4b0420f2f1b7694aa07b438f (diff)
ripple/fossil/mount: serve a small, static filesystem
Serve up an entirely hardcoded minimal filesystem tree,
so we can see most of the FUSE plumbing working already.

Change-Id: I13c4b534c8dd159d2d2e177497b33f1bec3849ad
Diffstat (limited to 'ripple/fossil/Cargo.toml')
-rw-r--r--ripple/fossil/Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/ripple/fossil/Cargo.toml b/ripple/fossil/Cargo.toml
index 86972c8..0634152 100644
--- a/ripple/fossil/Cargo.toml
+++ b/ripple/fossil/Cargo.toml
@@ -16,12 +16,13 @@ fuser = { version = "0.11.0", optional = true }
 log = { version = "0.4.14", optional = true }
 libc = { version = "0.2.112", optional = true }
 env_logger = { version = "0.9.0", optional = true }
+lazy_static = { version = "1.4.0", optional = true }
 
 [build-dependencies]
 prost-build = "0.8.0"
 
 [features]
-wip-mount = ["fuser", "log", "libc", "env_logger"]
+wip-mount = ["fuser", "log", "libc", "env_logger", "lazy_static"]
 
 [[bin]]
 name = "mount"