summary refs log tree commit diff
path: root/ripple/fossil/Cargo.toml
diff options
context:
space:
mode:
authoredef <edef@unfathomable.blue>2022-05-03 14:03:12 +0000
committeredef <edef@unfathomable.blue>2022-05-03 16:04:29 +0000
commitfdf83f8681bb3531f6441f9d0a021ca9dcd36c45 (patch)
treed8a1ec0acc662a2ab3c15568d040f9d5c5d8e6de /ripple/fossil/Cargo.toml
parent16e9d6fbbc1894b0706378a42123dc01d812e41e (diff)
ripple/fossil: add digest_from_str and digest_str
These decode digests to and from zbase32 for user-facing uses.

Change-Id: Ibd2db960044a97812d18d1a3c107521d78bd7f24
Diffstat (limited to 'ripple/fossil/Cargo.toml')
-rw-r--r--ripple/fossil/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/ripple/fossil/Cargo.toml b/ripple/fossil/Cargo.toml
index a1f39fb..6e1bf7b 100644
--- a/ripple/fossil/Cargo.toml
+++ b/ripple/fossil/Cargo.toml
@@ -20,6 +20,7 @@ lazy_static = "1.4.0"
 bao = "0.12.0"
 anyhow = "1.0.53"
 clap = { version = "3.1.15", features = ["derive"] }
+zbase32 = "0.1.2"
 
 [build-dependencies]
 prost-build = "0.8.0"