summary refs log tree commit diff
path: root/ripple/nix/default.nix
diff options
context:
space:
mode:
authorV <v@unfathomable.blue>2022-02-16 06:32:07 +0100
committerV <v@unfathomable.blue>2022-02-16 06:32:07 +0100
commit839075b6a45368239baa8e6fc5ae54aecbdf093a (patch)
tree6a9a4f297ac118834fe15a5d4163e4d3000b579a /ripple/nix/default.nix
parente65857d3e8a2f0ae58982834f1298cf545d22fae (diff)
ripple/nix: update sources.json
It's been a while since we've done this, and there are some great new
changes in the Rust compiler and standard library. As a bonus, rustfmt
now features the `imports_granularity = "One"` variant, so we can use
unmodified tooling again.

Change-Id: I228e4e5919f53b6a77e07a5c99420936c89016c3
Diffstat (limited to 'ripple/nix/default.nix')
-rw-r--r--ripple/nix/default.nix8
1 files changed, 0 insertions, 8 deletions
diff --git a/ripple/nix/default.nix b/ripple/nix/default.nix
index 590aec6..d4edeef 100644
--- a/ripple/nix/default.nix
+++ b/ripple/nix/default.nix
@@ -7,14 +7,6 @@ in import sources.nixpkgs {
     (final: prev: {
       # This was not available in nixpkgs at the time of writing.
       naersk = final.callPackage sources.naersk {};
-
-      rustfmt = prev.rustfmt.overrideAttrs ({ patches ? [], ... }: {
-        patches = patches ++ [
-          # Adds an option variant that merges all use statements into a single block.
-          # Taken from https://github.com/rust-lang/rustfmt/pull/4680
-          ./Implement-One-option-for-imports_granularity-4669.patch  
-        ];
-      });
     })
   ];
 }