summary refs log tree commit diff
path: root/ripple/nix/default.nix
diff options
context:
space:
mode:
authorV <v@unfathomable.blue>2021-08-14 03:10:08 +0200
committerV <v@unfathomable.blue>2021-08-14 04:03:46 +0200
commitdcae0f9c8a94f05bf55cf9b6fbc773502ab5784f (patch)
treef90046544ae955e684f9ffa957c1f43cc5b4e6c5 /ripple/nix/default.nix
parent3b4eaeaf282af63a4a1a16e13a5d4d4a2ffea910 (diff)
ripple/nix: build everything with naersk
Yes, it really is that simple. Naersk is great!

Change-Id: I183f5bd0d2547a368f32bbc42fddf03e7cb03331
Diffstat (limited to 'ripple/nix/default.nix')
-rw-r--r--ripple/nix/default.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/ripple/nix/default.nix b/ripple/nix/default.nix
index cf4273b..590aec6 100644
--- a/ripple/nix/default.nix
+++ b/ripple/nix/default.nix
@@ -5,6 +5,9 @@ let sources = import ./sources.nix {};
 in import sources.nixpkgs {
   overlays = [
     (final: prev: {
+      # This was not available in nixpkgs at the time of writing.
+      naersk = final.callPackage sources.naersk {};
+
       rustfmt = prev.rustfmt.overrideAttrs ({ patches ? [], ... }: {
         patches = patches ++ [
           # Adds an option variant that merges all use statements into a single block.