summary refs log tree commit diff
path: root/ripple/shell.nix
diff options
context:
space:
mode:
authoredef <edef@unfathomable.blue>2022-02-07 23:37:33 +0000
committeredef <edef@unfathomable.blue>2022-02-07 23:37:33 +0000
commit06aacbdde07209337c1faad0e0763d3c093400c6 (patch)
treebda621eab45425b5c2020375bbf9a187115c3219 /ripple/shell.nix
parent39ac8aee29fc34656b79617018d5250a50c96404 (diff)
ripple/shell.nix: make cc1 available for minitrace testing
Change-Id: Ie88130942865aa73bbdd9a3ddd71d9f5ef5914ab
Diffstat (limited to 'ripple/shell.nix')
-rw-r--r--ripple/shell.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/ripple/shell.nix b/ripple/shell.nix
index 03804c7..6c67ab5 100644
--- a/ripple/shell.nix
+++ b/ripple/shell.nix
@@ -4,6 +4,8 @@
 
 with import ./nix;
 
+let inherit (gcc) cc; in
+
 mkShell {
   packages = [
     cargo
@@ -20,4 +22,6 @@ mkShell {
 
   # needed by prost-build
   PROTOC = "protoc";
+
+  MINITRACE_CC1 = "${cc}/libexec/gcc/x86_64-unknown-linux-gnu/${cc.version}/cc1";
 }