summary refs log tree commit diff
path: root/ripple/shell.nix
diff options
context:
space:
mode:
authorV <v@unfathomable.blue>2021-08-12 07:47:05 +0200
committerV <v@unfathomable.blue>2021-08-14 03:53:14 +0200
commit5703ed3e3b6e8f8d959525acb866d6f3c867327e (patch)
tree8f3dac70dfe0f4cf6c8a283145705927c07d3895 /ripple/shell.nix
parent47db036c9e288810a8988f1ff92746daad3a15c4 (diff)
ripple: add a basic development shell and .envrc
Let's start with some basic build tooling, and some extra dependencies
to let us use rust-analyzer with the pinned version of Rust.

Change-Id: I1dd59277d29680ba89efdc7672668b3b095ef4a7
Diffstat (limited to 'ripple/shell.nix')
-rw-r--r--ripple/shell.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/ripple/shell.nix b/ripple/shell.nix
new file mode 100644
index 0000000..9282613
--- /dev/null
+++ b/ripple/shell.nix
@@ -0,0 +1,16 @@
+# SPDX-FileCopyrightText: V <v@unfathomable.blue>
+# SPDX-License-Identifier: OSL-3.0
+
+with import ./nix;
+
+mkShell {
+  packages = [
+    cargo
+    cargo-watch
+    clippy
+
+    # needed by rust-analyzer
+    rustc  # core crate code
+    rustfmt  # format-on-save
+  ];
+}