summary refs log tree commit diff
path: root/ripple/shell.nix
diff options
context:
space:
mode:
authoredef <edef@unfathomable.blue>2021-08-14 21:28:14 +0000
committeredef <edef@unfathomable.blue>2021-08-14 21:28:14 +0000
commitdb7c54f92f386a94db8af7a12626d2657b4dd640 (patch)
tree4baba57bac54c68823a834c0f8aa97b24cfec7a2 /ripple/shell.nix
parentdcae0f9c8a94f05bf55cf9b6fbc773502ab5784f (diff)
ripple/fossil: a basic content-addressable store
Fossil stores content-addressed blobs of file contents and
Protobuf-encoded directory listings, backed by Sled.

Change-Id: I8b49de6342218ca00755cec980b1d0cfb18878a7
Diffstat (limited to 'ripple/shell.nix')
-rw-r--r--ripple/shell.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/ripple/shell.nix b/ripple/shell.nix
index 9282613..03804c7 100644
--- a/ripple/shell.nix
+++ b/ripple/shell.nix
@@ -1,4 +1,5 @@
 # SPDX-FileCopyrightText: V <v@unfathomable.blue>
+# SPDX-FileCopyrightText: edef <edef@unfathomable.blue>
 # SPDX-License-Identifier: OSL-3.0
 
 with import ./nix;
@@ -12,5 +13,11 @@ mkShell {
     # needed by rust-analyzer
     rustc  # core crate code
     rustfmt  # format-on-save
+
+    # needed by prost-build
+    protobuf
   ];
+
+  # needed by prost-build
+  PROTOC = "protoc";
 }