summary refs log tree commit diff
path: root/ripple/website/default.nix
diff options
context:
space:
mode:
authorV <v@unfathomable.blue>2021-02-25 21:17:45 +0100
committerV <v@unfathomable.blue>2021-02-25 21:55:23 +0100
commitf5c8a8537a336b60fd28af003572fa8883fc8354 (patch)
tree7374f969bae7709fa78388a0dc288f926ade1f3b /ripple/website/default.nix
parent2f487c3bf7cd8efd64f1d217edac732db98ff1c0 (diff)
ripple/website: init
This contains the source to Ripple's website, as it was published on
2020-10-07.

Change-Id: I4c871be79d8841b277d23ea741c8728ec5da8cc8
Diffstat (limited to 'ripple/website/default.nix')
-rw-r--r--ripple/website/default.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/ripple/website/default.nix b/ripple/website/default.nix
new file mode 100644
index 0000000..f72e5af
--- /dev/null
+++ b/ripple/website/default.nix
@@ -0,0 +1,16 @@
+let pkgs = import <nixpkgs> {};
+in pkgs.runCommand "ripple.unfathomable.blue" {
+  nativeBuildInputs = [ pkgs.lowdown ];
+} ''
+  mkdir $out
+  for x in ${./pages}/*.md; do
+    {
+      cat <<EOS
+  <!DOCTYPE html>
+  <title>$(lowdown -X title $x)</title>
+  <style>body { max-width: 72ch; margin: auto; }</style>
+  EOS
+      lowdown --html-no-head-ids $x
+    } >$out/$(basename $x .md).html
+  done
+''