summary refs log tree commit diff
path: root/fleet/hosts/vityaz/git.nix
diff options
context:
space:
mode:
Diffstat (limited to 'fleet/hosts/vityaz/git.nix')
-rw-r--r--fleet/hosts/vityaz/git.nix17
1 files changed, 3 insertions, 14 deletions
diff --git a/fleet/hosts/vityaz/git.nix b/fleet/hosts/vityaz/git.nix
index 7ef9f9d..19e46bc 100644
--- a/fleet/hosts/vityaz/git.nix
+++ b/fleet/hosts/vityaz/git.nix
@@ -32,29 +32,18 @@ with lib;
   users.groups.git = {};
 
   # TODO(V): Enable the reflog?
-  declarative.git.repositories = flip genAttrs (repo: {
+  declarative.git.repositories.basin = {
     hooks.post-receive = [
       # FIXME(V): There are more than a number of issues with this!
-      # - non-generic (we could use $GIT_DIR or such)
       # - requires an explicit remote (we could add this to the config)
       # - only updates trunk (even if other branches were pushed)
       # - has no way to filter specific branches from being published
       # - does not synchronize tags
       (pkgs.writeShellScript "sync-repository" ''
-        git push trieste:${repo} trunk
+        git push trieste:basin trunk
       '')
     ];
-  }) [
-    # TODO(V): Take the list of public repositories from hosts/trieste/git.nix
-    # (or do the inverse)
-    # (or put this information in a shared location)
-    "ripple"
-    "ripple-website"
-    "nixos-config"
-
-    # Note: private repositories are currently not configured here.
-    # If we find it acceptable to leak their names, they could take advantage of this module as well.
-  ];
+  };
 
   # TODO(V): Linting hooks (honestly, these should just go in CI)
   # - reuse lint