summary refs log tree commit diff
path: root/fleet/modules/cgiserver.nix
diff options
context:
space:
mode:
Diffstat (limited to 'fleet/modules/cgiserver.nix')
-rw-r--r--fleet/modules/cgiserver.nix11
1 files changed, 6 insertions, 5 deletions
diff --git a/fleet/modules/cgiserver.nix b/fleet/modules/cgiserver.nix
index 6cafbe0..a3e94c2 100644
--- a/fleet/modules/cgiserver.nix
+++ b/fleet/modules/cgiserver.nix
@@ -1,15 +1,16 @@
 # SPDX-FileCopyrightText: V <v@unfathomable.blue>
 # SPDX-License-Identifier: OSL-3.0
 
-{ config, lib, pkgs, modulesPath, ... }:
+{ config, lib, utils, pkgs, ... }:
 
 with lib;
 
 let
   cfg = config.services.cgiserver;
 
-  inherit (import "${modulesPath}/system/boot/systemd-unit-options.nix" { inherit config lib; })
-    serviceOptions socketOptions;
+  inherit (utils.systemdUtils.unitOptions)
+    serviceOptions
+    socketOptions;
 
   # TODO(V): These descriptions could use a bit of work.
   instanceOpts = { name, ... }: {
@@ -33,13 +34,13 @@ let
 
       serviceConfig = mkOption {
         description = "Extra options to put in the [Service] section of the application's service unit.";
-        inherit (serviceOptions.serviceConfig) type;
+        inherit ((serviceOptions { name = null; config = null; }).options.serviceConfig) type;
         default = {};
       };
 
       listenStreams = mkOption {
         description = "Addresses to listen on, in the format used by the ListenStream option of systemd.socket(5).";
-        inherit (socketOptions.listenStreams) type;
+        inherit (socketOptions.options.listenStreams) type;
         default = [ "/run/${name}/${name}.sock" ];
       };
     };