summary refs log tree commit diff
path: root/fleet/modules/web.nix
diff options
context:
space:
mode:
Diffstat (limited to 'fleet/modules/web.nix')
-rw-r--r--fleet/modules/web.nix4
1 files changed, 1 insertions, 3 deletions
diff --git a/fleet/modules/web.nix b/fleet/modules/web.nix
index 248f78b..b4328b7 100644
--- a/fleet/modules/web.nix
+++ b/fleet/modules/web.nix
@@ -8,7 +8,7 @@
     enable = true;
 
     # Snippets must be defined before they are used, so the mkBefore ensures they come first.
-    config = lib.mkBefore ''
+    extraConfig = lib.mkBefore ''
       (all) {
         log {
           output file /var/log/caddy/access.log
@@ -40,7 +40,5 @@
     '';
   };
 
-  systemd.services.caddy.serviceConfig.LogsDirectory = "caddy";
-
   networking.firewall.interfaces.ens3.allowedTCPPorts = [ 80 443 ];
 }