summary refs log tree commit diff
path: root/fleet/pkgs/cgiserver/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'fleet/pkgs/cgiserver/default.nix')
-rw-r--r--fleet/pkgs/cgiserver/default.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/fleet/pkgs/cgiserver/default.nix b/fleet/pkgs/cgiserver/default.nix
new file mode 100644
index 0000000..9e911d5
--- /dev/null
+++ b/fleet/pkgs/cgiserver/default.nix
@@ -0,0 +1,25 @@
+# SPDX-FileCopyrightText: V <v@unfathomable.blue>
+# SPDX-License-Identifier: OSL-3.0
+
+{ lib, buildGoModule, fetchzip, zstd }:
+
+buildGoModule rec {
+  pname = "cgiserver";
+  version = "1.0.0";
+
+  src = (fetchzip {
+    url = "https://src.anomalous.eu/cgiserver/snapshot/cgiserver-${version}.tar.zst";
+    sha256 = "14bp92sw0w6n5dzs4f7g4fcklh25nc9k0xjx4ia0gi7kn5jwx2mq";
+  }).overrideAttrs ({ nativeBuildInputs, ... }: {
+    nativeBuildInputs = nativeBuildInputs ++ [ zstd ];
+  });
+
+  vendorSha256 = "00jslxzf6p8zs1wxdx3qdb919i80xv4w9ihljd40nnydasshqa4v";
+
+  meta = with lib; {
+    homepage = "https://src.anomalous.eu/cgiserver/about/";
+    description = "Lightweight web server for sandboxing CGI applications";
+    license = licenses.osl3;
+    maintainers = with maintainers; [ V ];
+  };
+}