summary refs log tree commit diff
path: root/fleet/pkgs/overlay.nix
diff options
context:
space:
mode:
Diffstat (limited to 'fleet/pkgs/overlay.nix')
-rw-r--r--fleet/pkgs/overlay.nix10
1 files changed, 0 insertions, 10 deletions
diff --git a/fleet/pkgs/overlay.nix b/fleet/pkgs/overlay.nix
index 49cc524..95330fa 100644
--- a/fleet/pkgs/overlay.nix
+++ b/fleet/pkgs/overlay.nix
@@ -10,16 +10,6 @@ final: prev: {
   public-inbox = final.perlPackages.callPackage ./public-inbox {};
   public-inbox-init-lite = final.callPackage ./public-inbox-init-lite {};
 
-  # Fixes bundler complaining loudly if $HOME is read-only or unset
-  # Taken from https://github.com/rubygems/rubygems/pull/4724
-  # This is here because the CGit about filter invokes Asciidoctor,
-  # which otherwise causes its log to fill with spurious error messages.
-  # Can be removed once Bundler 2.2.23 or above makes its way into stable.
-  bundler = prev.bundler.overrideAttrs ({ patches ? [], ... }: {
-    patches = patches ++ [ ./permission-warnings-only-when-necessary.patch ];
-    dontBuild = false;
-  });
-
   # Fixes archives having silly permissions due to Postfix messing with the umask
   mlmmj = prev.mlmmj.overrideAttrs ({ patches ? [], ... }: {
     patches = patches ++ [ ./group-readable-archives.patch ];