summary refs log tree commit diff
path: root/fleet/pkgs/overlay.nix
diff options
context:
space:
mode:
Diffstat (limited to 'fleet/pkgs/overlay.nix')
-rw-r--r--fleet/pkgs/overlay.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/fleet/pkgs/overlay.nix b/fleet/pkgs/overlay.nix
new file mode 100644
index 0000000..1f645f0
--- /dev/null
+++ b/fleet/pkgs/overlay.nix
@@ -0,0 +1,24 @@
+# SPDX-FileCopyrightText: V <v@unfathomable.blue>
+# SPDX-License-Identifier: OSL-3.0
+
+final: prev: {
+  cgiserver = final.callPackage ./cgiserver {};
+  declarative-git-repository = final.callPackage ./declarative-git-repository {};
+  public-inbox = final.perlPackages.callPackage ./public-inbox {};
+  public-inbox-init-lite = final.callPackage ./public-inbox-init-lite {};
+
+  # Fixes bundler complaining loudly if $HOME is read-only or unset
+  # Taken from https://github.com/rubygems/rubygems/pull/4724
+  # This is here because the CGit about filter invokes Asciidoctor,
+  # which otherwise causes its log to fill with spurious error messages.
+  # Can be removed once Bundler 2.2.23 or above makes its way into stable.
+  bundler = prev.bundler.overrideAttrs ({ patches ? [], ... }: {
+    patches = patches ++ [ ./permission-warnings-only-when-necessary.patch ];
+    dontBuild = false;
+  });
+
+  # Fixes archives having silly permissions due to Postfix messing with the umask
+  mlmmj = prev.mlmmj.overrideAttrs ({ patches ? [], ... }: {
+    patches = patches ++ [ ./group-readable-archives.patch ];
+  });
+}