summary refs log tree commit diff
path: root/fleet/pkgs/naut/Cargo.toml
diff options
context:
space:
mode:
authorV <v@unfathomable.blue>2021-08-19 22:10:03 +0200
committerV <v@unfathomable.blue>2021-08-21 07:06:30 +0200
commitec4ff9199b75926fc0bed56f027035446ae7d021 (patch)
treebfb0982d010828cc2631a195ec16b8e08f261739 /fleet/pkgs/naut/Cargo.toml
parent7072571a0ee7ea217564ea0788d611d5c8eeadbc (diff)
fleet/pkgs/naut: a little commit notification bot
After a couple of days wrangling Rust's async ecosystem, we now have
an IRC bot that will announce new commits. This should hopefully give
people a better view into what we're working on!

Change-Id: Ie7b3be62afca3ad2a10cb04c15ff666c62408fa2
Diffstat (limited to 'fleet/pkgs/naut/Cargo.toml')
-rw-r--r--fleet/pkgs/naut/Cargo.toml17
1 files changed, 17 insertions, 0 deletions
diff --git a/fleet/pkgs/naut/Cargo.toml b/fleet/pkgs/naut/Cargo.toml
new file mode 100644
index 0000000..6b08d85
--- /dev/null
+++ b/fleet/pkgs/naut/Cargo.toml
@@ -0,0 +1,17 @@
+# SPDX-FileCopyrightText: V <v@unfathomable.blue>
+# SPDX-License-Identifier: OSL-3.0
+
+[package]
+name = "naut"
+version = "0.1.0"
+edition = "2018"
+
+[dependencies]
+anyhow = "1.0"
+tokio = { version = "1", features = [ "io-util", "macros", "rt-multi-thread", "net" ] }
+git2 = { version = "0.13", default-features = false }
+irc = { version = "0.15", features = [ "ctcp", "tls-native", "nochanlists" ] }
+tokio-stream = "0.1"
+toml = "0.5"
+pin-utils = "0.1"
+lazy_static = "1.4"