summary refs log tree commit diff
path: root/fleet/pkgs/naut/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'fleet/pkgs/naut/Cargo.toml')
-rw-r--r--fleet/pkgs/naut/Cargo.toml17
1 files changed, 17 insertions, 0 deletions
diff --git a/fleet/pkgs/naut/Cargo.toml b/fleet/pkgs/naut/Cargo.toml
new file mode 100644
index 0000000..6b08d85
--- /dev/null
+++ b/fleet/pkgs/naut/Cargo.toml
@@ -0,0 +1,17 @@
+# SPDX-FileCopyrightText: V <v@unfathomable.blue>
+# SPDX-License-Identifier: OSL-3.0
+
+[package]
+name = "naut"
+version = "0.1.0"
+edition = "2018"
+
+[dependencies]
+anyhow = "1.0"
+tokio = { version = "1", features = [ "io-util", "macros", "rt-multi-thread", "net" ] }
+git2 = { version = "0.13", default-features = false }
+irc = { version = "0.15", features = [ "ctcp", "tls-native", "nochanlists" ] }
+tokio-stream = "0.1"
+toml = "0.5"
+pin-utils = "0.1"
+lazy_static = "1.4"