summary refs log tree commit diff
path: root/ripple/fossil/Cargo.toml
diff options
context:
space:
mode:
authoredef <edef@unfathomable.blue>2022-05-01 18:53:01 +0000
committeredef <edef@unfathomable.blue>2022-05-01 18:53:01 +0000
commitacc115945c7788dea022a0899580e4326cf760a4 (patch)
tree13bba3255ec55f7c32bc4b17fd0eae652027a299 /ripple/fossil/Cargo.toml
parent035650d64b60a2f31af3ac8e26c3e7fbd2b6ca1b (diff)
ripple/fossil: benchmark Chunker using Criterion
Performance hovers around 300MiB/s on my machine.

Change-Id: I387ccbf065c0b667824ede0675e6a295722f6d4b
Diffstat (limited to 'ripple/fossil/Cargo.toml')
-rw-r--r--ripple/fossil/Cargo.toml7
1 files changed, 7 insertions, 0 deletions
diff --git a/ripple/fossil/Cargo.toml b/ripple/fossil/Cargo.toml
index 04d0824..4008691 100644
--- a/ripple/fossil/Cargo.toml
+++ b/ripple/fossil/Cargo.toml
@@ -22,3 +22,10 @@ anyhow = "1.0.53"
 
 [build-dependencies]
 prost-build = "0.8.0"
+
+[dev-dependencies]
+criterion = "0.3.5"
+
+[[bench]]
+name = "chunker"
+harness = false